Errors when starting QC-CALC Real-Time or QC-CALC SPC/Monitor (4.x)
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written: 04/23/2025
last modified: 04/25/2025

SYMPTOM
You are getting an error each time you try to start QC-CALC (typically a Run-Time Error 5, 6, or 457), and you can never get past that error.

CAUSE
This problem seems to happen because an incorrect value was written into one of the QC-CALC settings files. Below are the directions for finding the file that is causing the issues. These directions apply to QC-CALC Real-Time 4.x, QC-CALC Monitor 4.3, and QC-CALC SPC 4.0 and 4.1.

RESOLUTION
Here are the files that can cause this issue in the order they should be moved:

  • RealTimePlots-ScreenSettings.ini (only for QC-CALC Real-Time)
  • QC-CALC SPC-ScreenSettings (only for QC-CALC SPC 4.0 or 4.1)
  • QC-CALC Monitor-ScreenSettings (only for QC-CALC Monitor 4.3)
  • QcCalcOverrides.ini
  • QC-CALC-RT.ini (only for QC-CALC Real-Time)
  • QC-CALC-SPC.ini (only for QC-CALC SPC 4.0, 4.1, and QC-CALC Monitor 4.3)
  • QC-CALC.ini

NOTE: If you have been running parts on your inspection machine while QC-CALC has not been running, move the communication files to another location before proceeding with the following steps. Once QC-CALC is running again and you have verified that the Data Collection settings are correct (especially the location to save the part files), you can move the communication files back to the location where QC-CALC will be watching for them.


Follow the directions below for each of the files listed in the order they appear, until you can start the program again.

  1. Move the file out of the "C:\ProgramData\Prolink\QC-CALC 4.x\" directory into a known location, so you can either copy it back or email it to Prolink for repair.
  2. Try to start the program (QC-CALC Real-Time, QC-CALC SPC, or QC-CALC Monitor).
  3. If the error persists, shut down the program and move the same file back into the original folder, overwriting the new file that was created.
  4. Repeat these steps with the next file in the list until you find the file causing the error.

Once you have found the file causing the issues, email it to support@prolinksoftware.com along with a brief explanation of the steps taken and asking for the file to be fixed and returned to you. If the file having the problems was one of the "ScreenSettings.ini" files, do not send it to support. These files can be deleted at any time since they only control the screen locations of the windows within QC-CALC. When the program runs after that file has been removed you will see that all QC-CALC windows now appear in the center of the primary monitor instead of where they were previously.

ACCESSING THE PROGRAMDATA FOLDER

The configuration files for all Prolink software versions 4.0 and greater are located in C:\ProgramData\Prolink. The C:\ProgramData is a hidden folder by default. If you cannot find it, you have several options:

  • If you can open a Prolink product, go to Help > Open ProgramData Folder. That will open the hidden C:\ProgramData folder in Windows File Explorer.
  • If you can't get into a Prolink product, open Windows File Explorer, enter %programdata% in the address bar at the top of the window, and press Enter. That will take you to the hidden C:\ProgramData folder.
    • Alternatively, look for File Explorer's View options and enable "Show Hidden items" and then navigate to C:\. The ProgramData folder is now visible.


MORE INFORMATION

If none of the listed files appear to be causing the issue you will need to run the Prolink Gather Tool (Start > Programs > Prolink > Prolink Gather Tool 4.x). This is a separate application that is used to collect all of the settings files for the specified Prolink application into a .zip file. If you do not see this application in the Prolink area you can download a .zip file from our website containing the program. Use the Related Files area to download the .zip file then copy the Troubleshooter.exe file inside to the folder QC-CALC is installed in.

Double-click the .exe file in the QC-CALC folder, choose the QC-CALC program in the Product column, and click the Create File button. This will retrieve all the settings for QC-CALC, save them into a .zip file, and inform you of the file's location so you can email it to the support system.