Errors when starting QC-CALC Real-Time or QC-CALC SPC
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written: 01/25/2012
last modified: 04/08/2024

SYMPTOM

You are getting an error each time you try to start QC-CALC (typically a Run-Time Error 5, 6 or 457) and you can never get by that error.


CAUSE

This problem seems to happen because an incorrect value was written into one of the QC-CALC settings files. Below are the directions for finding the file that is causing the issues. These directions will work for either QC-CALC Real-Time or QC-CALC SPC.


RESOLUTION

Here are the files that can cause this issue in the order they should be moved:

  • RealTimePlots-ScreenSettings.ini (for QC-CALC Real-Time ONLY)
  • QC-CALC SPC-ScreenSettings (for QC-CALC SPC ONLY)
  • QcCalcOverrides.ini
  • QC-CALC-RT.ini (for QC-CALC Real-Time ONLY)
  • QC-CALC-SPC.ini (for QC-CALC SPC ONLY)
  • QC-CALC.ini

NOTE: If you have been running parts on your inspection machine while QC-CALC has not been running, you should move the communication files to another location while doing the following steps. Once QC-CALC is running again and you have verified that the Data Collection settings are correct (especially the location to save the .qcc files) you can move the communication files back to the location where QC-CALC will be watching for them.


Follow the directions below for each of those files in the order they are listed until you are able to start the program again.

  1. Move the file out of the c:\Prolink\QC-CALC 3.X\ directory into a known location so you can either copy it back again or email it to Prolink to be fixed.
  2. Try to start the program (QC-CALC Real-Time or QC-CALC SPC).
  3. If the error still happens, shut down the program and move that same file back into the original folder overwriting the new file that was created.
  4. Repeat these steps with the next file in the list until you find the file causing the error.

Once you have found the file causing the issues, email it to support@prolinksoftware.com along with a brief explanation of the steps taken and asking for the file to be fixed and returned to you. If the file having the problems was one of the "ScreenSettings.ini" files, do not send it to support. These files can be deleted at any time since they only control the screen locations of the windows within QC-CALC. When the program runs after that file has been removed you will see that all QC-CALC windows now appear in the center of the primary monitor instead of where they were previously.

MORE INFORMATION

If none of the listed files appear to be causing the issue you will need to run the Prolink Gather Tool (Start > Programs > Prolink > Prolink Gather Tool). This is a separate application that is used to collect all of the settings files for the specified Prolink application into a .zip file. If you do not see this application in the Prolink area you can download a .zip file from our website containing the program. Use the Related Files area to download the .zip file then copy the Troubleshooter.exe file inside to the folder QC-CALC is installed in.

Double-click the .exe file in the QC-CALC folder, choose the QC-CALC program in the Product column and click the Create File button. This will get all of the settings for your copy of QC-CALC, save them into a .zip file, and it can optionally email that file directly to the support system.

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Error Messages
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