QC-CALC - CKServe is not running error (ver. 2.3 - 2.4)
Print Friendly View
written: 01/30/2006
last modified: 03/26/2024

SYMPTOM

You get a CKServe is not Running Error when you Start the Program, but it was Running before (Windows NT or 2000)


CAUSE

If you changed operating system settings, installed software with different system DLLs, or installed a service pack, you may have damaged the Crypkey License service. You MUST be logged on as Administrator to work on the license service, and you must close all programs before you start working on the license.


RESOLUTION

  1. Logon as Administrator
  2. Go to Control Panel -> Services
  3. If the Crypkey License is set for automatic and is started, go to the WINNT directory (typically C:\WINNT) and run CKCONFIG.EXE.
  4. Remove the entry for the Prolink product that is reporting the error (if there is more than one entry for a product remove all entries for that product) and add it back in.
  5. Close CKCONFIG and try to start the Prolink program again.


MORE INFORMATION

If you still get an error or if the Crypkey License service was not running, you must install the service again. You need the files SETUPEX.EXE and CKS.EXE to install the service. To install the service:

  1. Run SETUPEX.EXE found in QC-CALC's install directory.
  2. If you do not find SETUPEX.EXE or CKS.EXE in the installed directory, copy them from the distribution CD-ROM. You cannot run them from the CD-ROM!).
  3. Run SETUPEX.EXE (it extracts files from CKS.EXE and may delete CKS.EXE when it finishes).
  4. Reboot the computer with a FULL POWER DOWN, not just a restart.
  5. Logon as Administrator again.
  6. Try running the Prolink program again. If it does not run, repeat the CKCONFIG.EXE procedure above.


If the software still does not run, the problem is probably with DLLs. You should install the Prolink product again.

Applies To

QC-CALC Enterprise v.2.40
QC-CALC Enterprise v.2.30