SOLVED: There is no record found in the IDs table. - EDL
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written: 01/30/2012
last modified: 09/16/2024

SYMPTOM

When running EDL, you may get emails that contain messages that look like the following:

"There was no record found in the IDs Table for record number x and dimension number y. The update to this measurement cannot occur. The new value would have been: xyz"


CAUSE

This happens because the QCC file was either compacted or purged

Why this occurs:

Oftentimes, a bad record gets in the system due to dirt on the part. The record is deleted when the part is remeasured, which is the correct course of action. However, sometimes users feel they need to get rid of the evidence, so they compact the database (via the Tools menu in QC-CALC SPC). This actually physically removes the deleted records.

When EDL loads records from a QCC file, it first checks for additions to the file and then reads through the transaction log for changes (edits). When the user deletes the records, QC-CALC logs the changes to the transaction log. The records are removed when the user purges or compacts the QCC file, but the transaction log still exists. When EDL starts reading through, it finds records in the transaction log that no longer exist. This causes the error message above. It's basically saying that it tried to update a record that no longer exists, couldn't find it, and gave up.


RESOLUTION

Generally, nothing needs to be done for this particular case since it is just an informational message.

However, it is strongly recommended that you DO NOT purge or compact QCC files when loading them via EDL. Doing so resets the internal date in the QCC file (by design to keep the database straight). When you do this, EDL assumes it has never seen the QCC file and loads the entire thing from scratch since it is no longer whole. Constantly purging and/or compacting the QCC files will cause a lot of data reloading, resulting in poor EDL performance and excess data in the SQL database.



MORE INFORMATION

Disable the menus if you have users purging or compacting databases to cover their tracks. If you are using regular password protection, this can be done via the Tools > Password menu in QC-CALC SPC. If you use the Administrative Tools and User Groups, you can use the Admin Tools > Manage User Groups menu. Edit the group and disable both menus in QC-CALC SPC under the Menu Disabler section of the Group Options screen.

Also, EDL's Tools > Options > QCC Monitoring menu has features for detecting a compacted/purged file.

Applies To

Enterprise Data Loader v.3.3

Category

Data Collection
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