SOLVED: There is no record found in the IDs table. - EDL
How to fix "no record found in the IDs table" error during an EDL load event
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written: 01/30/2012
last modified: 04/08/2024

SYMPTOM

When running EDL, you may get emails that contain messages that look like the following:

"There was no record found in the IDs Table for record number x and dimension number y. The update to this measurement cannot occur. The new value would have been: xyz"


CAUSE

This happens because the QCC file was either compacted or purged

Why this occurs:

Often times, a bad record gets in the system due to dirt on the part. When the part is remeasured, the record is deleted which is the correct course of action. However sometimes users feel they need to get rid of the evidence so they compact the database (via the Tools menu in QC-CALC SPC). This actually physically removes the deleted records.

When EDL loads records from a QCC file, it first checks for additions to the file and then it reads through the transaction log for changes (edits) to the file. When the user deletes the records, QC-CALC logs the changes to the transaction log. When the user purges or compacts the QCC file, the records are removed, but the transaction log is still existing. When EDL starts reading through, it finds records in the transaction log that no longer exist. This causes the error message above. It's basically saying that it tried to update a record that no longer exists, couldn't find it, and gave up.


RESOLUTION

Generally, there is nothing that needs to be done for this particular case since it is just an informational message.

However, it is strongly recommended that you DO NOT purge or compact QCC files when you are loading them via EDL. Doing so resets the internal date in the QCC file (by design to keep the database straight). When you do this, EDL assumes it has never seen the QCC file and loads the entire thing from scratch since the file is no longer whole. Constantly purging and/or compacting the QCC files will cause a lot of reloading of data resulting in poor performance of EDL and excess data in the SQL database.



MORE INFORMATION

If you have users that are purging or compacting databases to cover their tracks, simply disable the menus. If you are using regular password protection, this can be done via the Tools > Password menu in QC-CALC SPC. If you are using the administrative tool and groups, you can do this in the Admin Tools > Manage User Groups. Edit the group and then disable both menus in QC-CALC SPC under the Menu Disabler section of the Group Options screen.

Also, there are features you can use to detect a compacted/purged file in the Tools > Options > QCC Monitoring section of the Enterprise Data Loader.

Applies To

Enterprise Data Loader v.4.20
Enterprise Data Loader v.3.30

Category

Data Collection
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