Wrong QCC Version Error
Print Friendly View
written: 09/01/2006
last modified: 03/22/2024

SYMPTOM

You open QC-CALC 2.x and receive the following error:

Wrong QCC Version

CAUSE

This typically happens with users who have a previous version of QC-CALC such as QC-CALC 2.4. Once downloaded from our website, the evaluation of QC-CALC 3.0 is tried using existing production .qcc files. At this point everything works fine.

The problem happens when you go back to your production 2.4 system and try to open those same files.

QC-CALC 3.0 was designed to automatically upgrade any .qcc file which was created using QC-CALC version 2.x the first time the file is opened. This happens silently so you may not realize it has happened. Once the .qcc file has been upgraded to 3.0, the 2.x version can no longer read it.


RESOLUTION

First, we always recommend you make a copy of your \data directory before evaluating any new product. However, if you have converted the files and need to convert back to 2.x, perform the following steps:

  1. Go to Start > Programs > Prolink > Convert 3.0. This will launch the database conversion tool that is automatically installed with QC-CALC 3.0.
  2. On the first screen, choose the Version 3.0 to Windows Version 2.4 option and click OK.
  3. If you know which files you need to convert, choose the Single or Multiple Files option. Otherwise, choose Directories and click Include Subdirectories.
  4. Choose the source directory or files using the elipses button (...)
  5. Pick a new directory where the converted file(s) will be placed.
  6. Click OK.
  7. Once finished, a message will appear saying "Converting Finished".


Close the application and the error should no longer appear.

Applies To

QC-CALC Enterprise (Unicode) v.3.10
QC-CALC Enterprise for Gage v.3.00
QC-CALC Real-Time v.4.10
QC-CALC Real-Time v.3.00
QC-CALC SPC v.4.10
QC-CALC SPC v.3.00

Category

Error Messages
See more articles in this category