License lost w/Norton Speed Disk
Print Friendly View
written: 01/30/2006
last modified: 03/22/2024

SYMPTOM

License was lost after DEFRAGMENTING hard disk with Norton Speed Disk


CAUSE

If you defrag your hardrive using the default Windows defrag software, then you will be able to prevent the loss of your license. However, if you have defragged your hardrive using either Norton Speed Disk or Nuts & Bolts, use the instructions listed below to regain your license.


RESOLUTION

QC-CALC uses locking software known as CrypKey written by Kenonic Corp. Crypkey creates four special licensing files called QCCALC32.ENT, QCCALC32.KEY, QCCALC32.RST and QCCALC32.41S to control the licensing of QC-CALC. These files are declared as hidden - system files and reside in the same directory you install QC-CALC.

A problem occurs when you defragment your hard drive with Norton Speed Disk or Nuts & Bolts. The defragmentation software included in Symantec’s Norton Utilities moves the CrypKey licensing files, causing a loss of the license.

To solve this problem, open Speed Disk and choose File-> Options-> Customize-> Unmovable Files. Specify that the *.ENT, *.KEY and *.RST files cannot be moved and then Speed Disk can be run without having any effect on CrypKey licensing. *.41S files do not need to be specified. Remember to do a File-> Options-> Optimization-> Save to save your settings in the new profile. Check these menu choices as new versions of Speed Disk may change their location.

Applies To

QC-CALC Enterprise for Gage v.2.40
QC-CALC Real-Time v.4.10
QC-CALC Real-Time v.2.40
QC-CALC SPC v.4.10
QC-CALC SPC v.2.40
Site License - Classic v.2.40