SOLVED: Unfortunately there is not a valid assignable cause for this record - EDL
How to fix the EDL error "there is not a valid assignable cause for this record"
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written: 01/30/2012
last modified: 04/05/2024

SYMPTOM

When running Enterprise Data Loader (EDL), you may receive the following errors as your QCC files are uploaded.

"Unfortunately, there is not a valid existing assignable cause for this record (x) to map in the database."

"Unfortunately, there is not a valid existing corrective action for this record (x) to map in the database."


CAUSE

This is caused when QC-CALC is mapped to a different assignable cause/corrective action path than EDL. Because of this, EDL is attempting to find an assignable cause that does not exist in the database in the specified location in the QCC file.


RESOLUTION

Verify that the paths for QC-CALC match those of EDL. Normally it is recommended that you use common assignable cause/corrective action paths.

In QC-CALC RT or SPC - You can set these paths to a common path on your network in the Tools > Options > Assignable Cause area.

In EDL - You can set these paths as a default value in the Tools > Options > Assignable Cause area. You can also override the paths at the individual EDL event level in the Overrides screen. Please keep in mind that EDL is running as a service so the path cannot be a mapped drive. You must use UNC paths for all path settings in EDL (unless the drive is local such as the C drive).

As a best practice if you have multiple copies of QC-CALC, you should use the Administrative Tool to create groups with common settings. This will allow you to set the assignable cause path once and have it automatically pushed down to the individual copies of QC-CALC throughout your plant.



MULTIPLE SETS OF ASSIGNABLE CAUSES

If you have multiple sets of assignable causes due to different departments with different sets of needs, the easiest way to set it up is to break them into separate areas as follows:

  1. For the main QCC path, break it into multiple subfolders by department.
  2. Create the different sets of assignable cause/corrective actions files in different folders (either in subfolders or with different file names) under the common administrative area.
  3. Use the administrative tool to set up groups that point to the appropriate sets of AC/CA files.
  4. Assign the appropriate PC workstations to those groups.
  5. In EDL, when you create the event, create a different event for each department that points to the specific subfolder for that department. Inside the event, use the AC/CA override paths to specify the department specific AC/CA paths for that event.

Although this sounds complicated when first reading, if you follow the above instructions it actually makes a lot of sense. It's just a matter of splitting the assignable cause and corrective action lists across multiple departments so each department has their own QCC files and their own lists. This then follows through to EDL where they have their own EDL events.



MORE INFORMATION

For more information on running EDL as a service, please refer to the EDL User manual or the article listed in the links on the right.